ZGI_DVD - No Propaganda

Need to sharpen your sword? Or perhaps your lantern ran out of fuel? Well come on in, drink some rye and let Jack sharpen your blade and fill that lantern!

Moderator: KM3K

User avatar
KM3K
TZL Administrator
TZL Administrator
Posts: 166
Joined: Tue Jul 01, 2008 9:31 pm
Location: Flood Control Dam #3
Contact:

Re: ZGI_DVD - No Propaganda

Post by KM3K » Thu Jan 06, 2011 8:26 am

Thanks for the info, Zorkmid. Maybe there's something missing from the instructions for when you can't use the installer. I'll make a note of it and look into it when I get some time.

Zorkmid
A white house, what?
Posts: 3
Joined: Sun Nov 14, 2010 9:25 pm

Re: ZGI_DVD - No Propaganda

Post by Zorkmid » Thu Mar 24, 2011 1:29 am

One thing I forgot to mention in my particular DVD Rom version of Zork Grand Inquisitor....it only has an inquis.zix file. There is no inquisc.zix.

Thus, in the manual instructions provided by KM3K for when the DVD setup program will not run correctly, I can only make the corrections on the existing inquis.zix file. I can manually add in inquisc.zix, but it is not on the DVD to begin with. I just wanted to mention this as it may have something to do with the no propaganda issue.

henshu
A white house, what?
Posts: 2
Joined: Wed Jun 22, 2011 7:22 pm

Re: ZGI_DVD - No Propaganda

Post by henshu » Wed Jun 22, 2011 7:26 pm

My first install attempt was with the DVD, and I had a multitude of issues. No propaganda, no start videos, and crashing at the restore window. I tried again with the CD version, and now I'm just down to no propaganda. Though if there is supposed to be background music at this point in the game (I can't remember) I don't have that either.

henshu
A white house, what?
Posts: 2
Joined: Wed Jun 22, 2011 7:22 pm

Re: ZGI_DVD - No Propaganda

Post by henshu » Wed Jun 22, 2011 9:29 pm

Alrighty, after posting my last I was able to get the installer to work. So after going through things again, the game now has propaganda, music, and videos... but crashes when I try to save or restore. Tips?

Edit: well hey, I think I've got it figured out. For some reason my install folder was set to read only, so I unchecked that which of course didn't fix things, but after I deleted the old *.sav files, which were obviously corrupted, I was able to save without issue! Of course that doesn't fix restoring, but I saw a tip on other forum. For some reason, visiting the credits directly before restoring prevents it from crashing. Weird.
I now have a (more or less) fully functioning install of Z:GI! Thanks guys, your already available wisdom was infinitely helpful.

skorch82
A white house, what?
Posts: 1
Joined: Sun Apr 01, 2012 8:00 pm

Re: ZGI_DVD - No Propaganda

Post by skorch82 » Sun Apr 01, 2012 11:18 pm

So seems this thread has gone quiet for quite some time now... but I think I figured out the solution to this problem.

I'm using the CD version of the game, and I was also unable to run the installer. I'm on Win 7 64 bit.
I presume that most of this will also apply to the DVD version of the game as well.

If you follow the steps to copy all the files from the CD as the guide linked on this site explains (I cannot post links, but it's in the links at the top of the forum), you will get to a point where you try to run the game and there will be no propaganda playing. The problem seems to be in that when the game is installed normally, some of these copied files get new extensions.

Luckily, I had an old installation on my drive to compare with. How I solved the problem was:
1) Once you have all your files copied, and your inquisitor.zix file modified, go to the zgi_mx folder in your main or CD1 directory on your drive.
2) You should see a bunch of files, and two folders. One called NULL and the other called MINMAX
3) Copy all the files from the MINMAX directory to the zgi_mx directory, one level up.
4) You should see a bunch of .SRC files in this directory now
5) Rename all the .SRC files with a .RAW extension (replacing .SRC)

After you do this, if you followed everything else in the guide, you should have your audio.

Hope this helps!!

Post Reply